What browswer are you using to write on this board?

So, I'm a language teacher and editor (as well as a hobby game-designer), and it is is driving me crazy that I can't edit my post when I see a error in something that I've written.

I use Google Chrome. Am I using the wrong browser or do I have some setting misaligned? Please help.

Comments

  • edited March 2018
    I'm also using Chrome, but not having any trouble editing; when I hover over one of my old posts, the little black gear wheel appears in the upper right corner and when I click on that, the editing panel opens.

    Edit: I just edited this post to check that it all works.
  • Works for me, too. I use a Firefox variant ("Waterfox" at the moment). Do you get the edit option and it doesn't work, or can't you see the edit function at all?
  • Firefox user here.

    The "Edit" command is very well-hidden, under a tiny black gear-shaped icon which only appears on screen when you move your mouse to the upper-right corner of a post you wrote (while logged in of course).
  • Firefox on a mobile no problem editing.
  • When I hover, I can see the gear that James and Rafu mentions but no menu appears. It occassionally works, so I know what to look for, but occassionally is really only 10% of the time.
  • Do I have to have Javascript or something else turned on?
  • Javascript is on.
  • But when I try to bookmark this page, the site warns me that I don't have Javascript turned on.
  • @Hopeless_Wanderer: Could you try launching an incognito window (Should be under the File menu) and logging in there? It could possibly be an extension you have that's causing this interaction.
  • I'm using Firefox and I have to click the gear, then I see the "Edit" option.
  • Using Chrome; never had an issue editing anything.
  • @James_Stuart I just tried you suggestion. It didn't work, but it reminded me of something else. When I used the @ symbol for you name, it didn't bring up the list of users like it used to. Are those two problems related?
  • your suggestion
  • Probably! It seems like a javascript error in both parts. I think there's probably something non-standard in how your browser is setup, but beyond that, it's hard to say.
  • So, I'm a language teacher and editor (as well as a hobby game-designer), and it is is driving me crazy that I can't edit my post when I see a error in something that I've written.

    I use Google Chrome. Am I using the wrong browser or do I have some setting misaligned? Please help.

    Most of the time it's Chrome, though occasionally in Safari.
  • Okay, I've narrowed down the problem. I'm using MS edge and I have the same problem. I also turned JS off and on again in Chrome and whitelisted this site. Still no joy. I think the problem is with my firewall. Is anyone here using Zone Alarm?
  • Tried whitelisting this site for popups; no joy.
  • Tried various setting changes with my firewall and virus scanner; no joy.
  • Install a plain vanilla Firefox browser with no add-ons first, does it work?
    Try it with another device (i.e. mobile) in the same network, does it work?
Sign In or Register to comment.